Port forwarding for iptables (DMZ)

Port forwarding for iptables (DMZ)

If you have a network gateway which is running Linux you might sometimes want to allow access to machines behind it from the internet.

This is simple enough to do with iptables, which you will probably be using for the gateway's normal operation anyway.

Normally you'd deny all incoming connections to a gateway machine as opening up services and ports could be a security risk.

If you have a gateway machine and wish to forward connections on port 80 to an internal machine then you'd create the following rules:

iptables -A PREROUTING -t nat -i eth1 -p tcp --dport 80 -j DNAT --to 192.168.1.50:80
iptables -A FORWARD -p tcp -m state --state NEW --dport 80 -i eth1 -j ACCEPT

These two rules are fairly simple - the first says that all incoming tcp connections arriving destined for port 80 should be sent to the internal machine 192.168.1.50 (also on port 80).

This rule alone doesn't do the job though, we also have to accept the incoming connection. This is the job of the second rule which says that new connections on port 80 should be accepted on the external device eth1.

To increase security you could limit this forwarding to only work when connections are coming from a particular address with the use of the "--source" flag:

iptables -A PREROUTING -t nat -i eth1 -p tcp --source 11.22.33.44 \
--dport 80 -j DNAT --to 192.168.1.50:80

close port 80 to all users except for a few ips ?

close port 80 to all users except for a few ips ?
> how do i close port 80 to all users except for a few ips ?
> the generic match
> of --dport doesn't work for me.

Why not ?
Are these users on your LAN or on the internet ?
Do these users have a fixed IP ?

iptables -P INPUT DROP
iptables -A INPUT -s -p tcp --dport 80 -j ACCEPT
...
iptables -A INPUT -s -p tcp --dport 80 -j ACCEPT


Or maybe you can use the MAC address match.

iptables -P INPUT DROP
iptables -A INPUT -m mac --mac-source -p tcp --dport 80 -j
ACCEPT
...
iptables -A INPUT -m mac --mac-source -p tcp --dport 80 -j
ACCEPT

Setting up a basic MikroTik hotspot

Setting up a basic MikroTik hotspot
Mikrotik RouterOS includes an excellent hotspot solution. Read on for details on getting a basic hotspot going using RouterOS on any standard x86 PC hardware or a RouterBOARD.

The RouterOS hotspot solution is very powerful and only the very basics of the solution are covered here; just enough to get you started.
Introduction

This article assumes you want to set up a basic hotspot as shown in the diagram below. If you have a DNS server integrated into your router the same rule applies, just use the router IP for your DNS server as well.

To help get you started MikroTik now include a combined RADIUS server and simple web administration package for RouterOS called the User Manager. This provides a much simpler means of user administration then the command line or Winbox. The User Manager package is included standard with all versions of RouterOS from about 2.9.35 onwards.

Advanced users might wish to provide their own RADIUS server, however this is outside the scope of this article.
Getting the Hotspot to Work

First of all you will need to have a copy of RouterOS. You can purchase a license or download a 24-hour trial from Mikrotik. RouterBOARDs also usually come with RouterOS pre-licensed and installed. You will also need a computer with at least a 100MHz CPU, 32MB RAM and an IDE hard disk, or a RouterBOARD. Either method you choose will need a compatible wireless card and Ethernet adapter, or two Ethernet adapters with one connected to a standard wireless access point. You should check your hardware against the RouterOS compatibility list.

If you are installing RouterOS for the first time, download the ISO image from Mikrotik and burn it to CD. Note that installation of RouterOS will completely wipe the contents of the hard disk! Boot the PC off this CD and install the following packages:

* System
* DHCP
* Wireless
* Hotspot
* Proxy
* User Manager (optional)
* Security (optional - recommended)
* Advanced tools (optional)

Now to get started. Log onto the PC as admin with no password. If this box intended for deployment, change set a password by typing in password at the prompt. Change the hostname by typing in name.

Assign an IP address to each interface. As this is going to be set up as a router, they will need to be on a different subnet. Substitute wlan1 with ether2 if you have a separate access point.

[admin@Mikrotik] > ip address add address=192.168.24.3/24 interface=ether1
[admin@Mikrotik] > ip address add address=192.168.30.1/24 interface=wlan1

Now we need to add a default route to the IP of the internet router.

[admin@MikroTik] > ip route add gateway 192.168.24.1

Enable the wireless interface and set it to run as an access point as below. If you have an access point instead, ignore the command below, make sure it is running with no security enabled, use a suitable SSID and channel and change its admin password.

[admin@Mikrotik]> interface wireless set wlan1 ssid="My HotSpot" band=2.4ghz-b mode=ap-bridge

Run the hotspot setup as below. Substitute the values in italics to suit your network. The user account bears no relation to the admin account and is used for the hotspot service only. You may also need to add a host record to your DNS server for the hostname of the hotspot box. Make sure the address pool does not conflict with any devices using static IPs, such as access points.

[admin@MikroTik] > ip hotspot setup
hotspot interface: wlan1
local address of network: 192.168.30.1/24
masquerade network: yes
address pool of network: 192.168.30.2-192.168.30.99
select certificate: none
ip address of smtp server: 0.0.0.0
dns servers: 192.168.24.2
dns name: hotspot.mydomain.net (or leave this blank)
name of local hotspot user: user
password for the user: password

That’s the guts of it there. Fire up your laptop, associate to the network and try to access a web page. You should be redirected to the hotspot login page instead where you can enter the user credentials you set up earlier. Click the thumbnails for a full view of the default page.

You should now be able to access the web normally and a pop-up window will display your connection time and data usage as you go.

Bear in mind I have left out the certificate so usernames and passwords will be sent as plain text. If you intend on deploying the hotspot, you should install a certificate on it and set up SSL to protect account data from being sniffed.
Setting up User Manager

The User Manager is a nice and simple web administration for setting up user account for the MikroTik hotspot and other services. It can be hosted on either the same box as the hotspot or located in a separate box on the same local network. One User Manager package can control multiple hotspots.

Before getting the User Manager set up, check for any existing hotspot account and remove them. To do this, run the following command:

[admin@MikroTik] > ip hotspot user print
Flags: X - disabled, D - dynamic
# SERVER NAME ADDRESS PROFILE UPTIME
0 fred default 0s

If any items are listed (in this case bob), run the following command to remove them:

[admin@MikroTik] > ip hotspot user remove 0

You can delete multiple items at the same time, simply separate each item number with a comma.

To get the User Manager working we first need to add a customer login. This is used to access the UM web administration. Make sure you substitute the values in italics to suit.

[admin@MikroTik] > tool user-manager customer add login=hs_admin password=password

Now we need to add the hotspot as a RADIUS client to the user manager. This is done under the user manager router section. The shared secret can be any string of text and should be reasonably long and complex. If you are setting the user manager up on the same box as the hotspot, use 127.0.0.1 for the IP address.

[admin@MikroTik] > tool user-manager router add ip-address=hotspot-ip shared-secret=12345 subscriber=hs_admin

In return, we need to set up the hotspot to use RADIUS for user authentication. First this involves creating a RADIUS client to communicate with the UM. Remember that if you have both services on the same box, the IP address should be set to 127.0.0.1. The secret should be the same as you set up above.

[admin@MikroTik] > radius add service=hotspot address=ip-address secret=12345

Now we tell the hotspot itself to use a RADIUS client. First bring up a list of hotspot profiles:

admin@MikroTik] > ip hotspot profile print

Locate the profile in use and type the following command where 1 is the number of the profile to configure:

[admin@MikroTik] > ip hotspot profile set 1 use-radius=yes

Now we are done with configuration. Browse to http://router-ip/userman where router-ip is the IP address of the box you are configuring UM on. Login using the customer username and password created earlier.

Click on the User menu and select Add. Enter in a username, password and any other details you wish. You can limit the speed the client can access the internet by selecting the Rate limits checkbox and typing in a suitable speed (e.g. for a flat 128kBps download/64kBps upload speed limit simply type in 128k in the RX field and 64k in the TX field).

Click Add and you should be able to now access the hotspot using the username and password you specified. If you want to generate a printable ticket for the users you set up, click on the Users link, select the users to make a ticket for, click Generate and select the number of tickets per page.
Other Tips

You can also go a step further and play with some other available options, as this only skims the surface of the hotspot capabilities. I’ll post more notes as I play with additional options.

* To disable communication between wireless clients (recommended), disable the default forward option on the wireless interface.
interface wireless set wlan1 default-forward=disabled
* To set up a walled garden (pages people can access without authenticating), use the following command:
ip hotspot walled-garden add dst-host=www.website.com
* To limit client bandwidth type the following, replacing profilename with the current hotspot profile in use and speed with the rate limit in bits per second:
ip hotspot profile set profilename rate-limit=”speed“
* You can customise the login and status pages by editing the files in the hotspot directory of the Mikrotik box. You can access these via FTP.

Hot Spot On Mikrotik Step By Step

Hot Spot On Mikrotik Step By Step
lengkapnya nih

Quote:
/ radius
add service=hotspot called-id="" domain="Radius" address=192.168.1.3 \
secret="123456" authentication-port=1812 accounting-port=1813 \
timeout=900ms accounting-backup=no realm="" comment="" disabled=no
/ radius incoming
set accept=yes port=1700

/ ip hotspot
add name="Hotspot2" interface=Lokal address-pool=hs-pool-1 profile=hsprof2 idle-timeout=none keepalive-timeout=none disabled=no

/ ip hotspot profile
add name="hsprof2" hotspot-address=192.168.1.3 dns-name="hotlink.net" \
html-directory=hotspot rate-limit="" http-proxy=192.168.1.3:3128 \
smtp-server=0.0.0.0 login-by=http-chap split-user-domain=no use-radius=yes \
radius-accounting=yes radius-interim-update=5s nas-port-type=0 \
radius-default-domain="Radius" radius-location-id="" \
radius-location-name=""

/ tool user-manager router
add subscriber=admin name="Hotlink.net" ip-address=192.168.1.3 \
shared-secret="123456" comment="" disabled=no

/ ip dns static
add name="hotlink.net" address=192.168.1.3 ttl=1d
kmudian setelah itu bikin user dan di http://hotlink.net/userman

eh jgn lupa bikin dulu customernya ... biar bisa masuk ke userman

Quote:
/ tool user-manager customer
add subscriber=admin login="admin" password="admin" company="HOTlink" \
city="Bandung" country="Indonesia" date-format="%m/%d/%y" \
email="admin@hotlink-id.net" time-zone=+00:00 permissions=owner \
parent=admin comment="" disabled=no

Blocking MAC Address on MIKROTIK

Blocking MAC Address on MIKROTIK
OK I think I found it. If you really want to drop this user's MAC.

/ip firewall filter chain=input action=drop src-mac-address=00:1D:0F:E2:E3:D0 \
comment="Drop conections to the router"

/ip firewall filter chain=forward action=drop src-mac-address=00:1D:0F:E2:E3:D0 \ comment="Drop connections through the router"

Bt then he can just spoof another MAC address (if he knows how) and keep trying.

HOTSPOT mikrotik

HOTSPOT mikrotik

System operasi adalah aplikasi dasar yang dibutuhkan seperangkat atau kumpulan

perangkat komputer untuk dapat menjalankan fungsi fungsi dasarnya, setiap system

operasi memiliki kelebihan dan fungsi yang berbeda sesuai dengan kebutuhan

penggunaanya, setelah system operasi terpasang pada perangkat komputer selanjutnya

akan di tambahkan aplikasi aplikasi yang berfungsi mengatur kinerja tertentu dari system

yang telah berjalan.

Dalam wacana kali ini akan disampaikan mengenai administrasi jaringan dengan

basis system operasi Mikrotik Router OS, system operasi ini adalah system turunan dari

Linux yang di kembangkan lebih lanjut sehingga menjadi system operasi yang cukup

handal untuk fungsi administrasi ( pengaturan ) jaringan computer. System operasi

Mikrotik merupakan system operasi komersial, hal ini sebanding dengan kemudahan

yang diberikan dalam penerapannya dibandingkan dengan system operasi berbasis Linux

yang lain.

Untuk melakukan pengaturan terhadap fungsi jaringan Mikrotik memberikan

beberapa pilihan akses, antara lain; melalui Command Line Interface ( CLI ), melalui

Winbox sebagai aplikasi control melalui system operasi Windows, dan Web Inerface yang

dapat di akses melalui web browser.

Tampilan control memalui Winbox :

Langkah awal untuk melakukan konfigurasi melalui winbox, adalah melakukan

download program winbox yang dapat diambil dengan melakukan download ke alamat IP

address router, dengan format : http://ip-router-mikrotik/winbox/winbox.exe

1. Jalankan aplikasi winbox pada PC windows yang terhubung ke jaringan Router

Mikrotik. Berikan informasi ; IP address, User Name dan Password, sesuai

dengan hak akses yang dimiliki.

2. Hak akses user pada Mikrotik secara garis besar terbagi dalam tiga group, antara

lain ; Read untuk user yang hanya dapat melakukan akses dan melihat konfigurasi

yang telah ada, Write untuk user yang dapat melakukan konfigurasi dengan

batasan fungsi tertentu dan hasil konfigurasi tidak bersifat permanen, Full untuk

user yang memiliki hak akses dan konfigurasi penuh terhadap system secara

keseluruhan.

Berikut ini adalah proses administrasi Router Mikrotik :

1. Fungsi pengaturan hak akses.

Pilih tombol “User”, menu yang tersedia :

+ = Menambah hak user akses

- = Menghapus hak user akses

X = Menonaktifkan hak user akses

= Mengaktifkan hak user akses

Contoh : Menambahkan user dengan nama : Operator dengan hak Full dan

password 1234.

a. Pilih menu +

b. Pada kolom “Username” diisi Operator.

c. Pada kolom “Password” diisi 1234

d. Pada menu “Group” diisi Full

e. Kemudian “Ok”

2. Fungsi pengaturan perangkat Ethernet Card / Lan Card

Pilih tombol “Interface”, kemudian pilih “Ethernet”

a. Perhatikan status setiap Ethernet card, pastikan dalam kondisi “enable”

b. Mac Address adalah alamat hardware yang unik dari setiap perangkat

dalam bentuk format 8 digit Hexadecimal dipisahkan oleh tanda “:”,Mac

Address penting untuk diperhatikan mengingat beberapa Internet Service

Provider / Network Access Provider menerapkan system keamanan

tambahan dengan melakukan “Lock” IP dibandingkan dengan “Mac

Address”, sehingga apabila ditemukan adanya koneksi dengan parameter

yang berbeda dengan informasi yang dimiliki secara otomatis tidak akan

dapat tersambung ke dalam network.

c. Secara default setiap perangkat Ethernet Card akan diberi nama dengan

format “ether(no-urut)” contoh : ether1, ether2, ether3 dst, nama perangkat

dapat dirubah dengan memilih interface yang akan dirubah dan tekan

tombol enter, sehingga ditampilkan informasi Ethernet Card, rubah nama

sesuai dengan yang diinginkan, kemudian pilih tombol “Apply” kemudian

“OK”

3. Fungsi pengaturan IP Address router.

Pilih tombol “IP”, kemudian pilih “Address”, menu yang tersedia

+ = Menambahkan IP

- = Menghapus IP

X = Menonaktifkan IP

= Mengaktifkan IP

Contoh : Menambahkan IP : 192.168.0.12 dengan netmask : 255.255.255.0 pada

interface Ethernet Card “ether1”

a. Pilih menu +

b. Pada kolom “IP Address” diisi 192.168.0.12

c. Pada kolom “Netmask” diisi 255.255.255.0

d. Pada kolom “Interface” pilih ether1

e. Pilih “Apply”

f. Kemudian “Ok”

4. Fungsi pengaturan DNS Address.

Pilih tombol “IP”, kemudian pilih “DNS”, pilih “Setting”

Pada kolom “Primary DNS” diisi dengan DNS Address yang diberikan oleh ISP /

NAP, begitu juga dengan “Secondary Address”.

Untuk memberikan penamaan pada alokasi IP yang kita miliki atau menambahkan

DNS untuk dipergunakan dalam lingkup internal dipergunakan “DNS Static”.

Penambahan “DNS static” dapat dilakukan dengan cara berikut :

a. Pilih Sub menu “Static” dari menu “IP DNS”

b. Pilih tombol +

c. Pada kolom “Name” isikan nama domain yang diinginkan, sebagai contoh;

pc-admin.routertest.com

d. Pada kolom “Address” isikan IP yang ingin ditranslasikan ke nama domain

“pc-admin.routertest.com”

e. Pilih “Apply”

f. Pilih “Ok”

Untuk aktifitas check, dapat dilakukan dengan menjalankan aplikasi “ping”

melalui DOS command prompt Windows, dengan format : ping address/domaintujuanI

contohnya dapat dilihat sebagai berikut IP 192.168.1.2 yang telah di atur “IP DNS

Static” menggunakan nama domain : pc-admin.routertest.com.

C:\>ping pc-admin.routertest.com

Pinging pc-admin.routertest.com [192.168.1.2] with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time<1ms ttl="128

Reply from 192.168.1.2: bytes=32 time<1ms ttl="128

Reply from 192.168.1.2: bytes=32 time<1ms ttl="128

Reply from 192.168.1.2: bytes=32 time<1ms ttl="128

Ping statistics for 192.168.1.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

5. Fungsi pengaturan Firewall

Mengingat pentingnya pengaturan firewall untuk integritas jaringan maka perlu

diperhatikan dengan seksama aliran data dan aksi yang akan diterapkan dalam

jaringan agar tidak terjadi kebocoran maupun sebaliknya hilangnya layanan

interkoneksi dalam jaringan.

Informasi yang diperlukan mengenai aliran packet data yang digunakan.:

INPUT : packet data yang masuk melalui interface jaringan

FORWARD : packet data yang diteruskan melalui interface jaringan

OUTPUT : packet data yang keluar melalui interface jaringan.

Informasi yang diperlukan mengenai aksi yang diterapkan, pada umumnya yang

sering dipergunakan adalah :

ACCEPT : menerima packet data untuk diproses lebih lanjut.

DROP : packet data tidak diproses lebih lanjut untuk selanjutnya dibuang.

REJECT : packet data di kembalikan ke pengirim dengan pesan penolakan.

Untuk masuk ke opsi firewall, pilih tombol “IP” kemudian pilih menu “Firewall”

Berikut ini beberapa contoh penerapan Firewall :

Blocking akses browsing dari ip 192.168.1.12 dengan tujuan akses ke

www.playboy.com.

a. Pergunakan menu “IP” kemudian pilih menu “Firewall” selanjutnya pilih “Filter”

b. Verifikasi ip dari www.playboy.com dengan melakukan ping ke domain tersebut.

c. Pilih menu +

d. Pilih Rule “Output”

e. Pada opsi “src-address” diisi dengan 192.168.1.12

f. Pada opsi “dst-address” diisi dengan IP www.playboy.com

g. Pada opsi Action pilih “drop”

h. Kemudian “Ok”

6. Fungsi pengaturan akses browsing.

Fungsi ini umumnya dibutuhkan ketika kita ingin melakukan pembatasan pada

user untuk tidak dapat mengakses web site dengan kategori atau konten tertentu,

misalkan web site yang berisi pornografi.

Untuk masuk ke fungsi ini, pilih tombol “IP” kemudian pilih menu “Web Proxy”,

menu yang tersedia :

+ = Menambahkan filter akses web

- = Menghapus filter akses web

X = Menonaktifkan filter akses web

= Mengaktifkan filter akses web

Sebagai contoh kita akan melakukan blocking dengan tujuan akses web ke

www.playboy.com :

a. Pergunakan menu “IP”, pilih sub menu “Web Proxy”

b. Pilih menu +

c. Pada opsi “src-address” diisi 0.0.0.0/0

d. Pada opsi “dst-address” diisi 0.0.0.0/0

e. Opsi “URL” diisi www.playboy.com

f. Pilihan “Method” di set ke “any”

g. Aturan pada “Action” di set ke “deny”

h. Kemudian “Ok”

7. Fungsi pengaturan bandwith per - IP Address.

Fungsi ini penting untuk diketahui mengingat harus adanya proses pembagian

bandwith yang akan diatur oleh administrator jaringan.

Untuk masuk ke fungsi ini, pilih tombol “Queues” kemudian pilih menu “Simple

Queues”, menu yang tersedia :

+ = Menambahkan aturan pemakaian bandwith

- = Menghapus aturan pemakaian bandwith

X = Menonaktifkan aturan pemakaian bandwith

= Mengaktifkan aturan pemakaian bandwith

Sebagai contoh ; membatasi pemakaian bandwith user dengan IP address :

192.168.2.51 dengan batasan pemakaian bandwith 12 kbps untuk upload dan 12 kbps

untuk download.

a. Pilih menu “Queues” kemudian pilih sub menu “Simple Queues”

b. Pilih tombol +

c. Pada opsi “Name” isi dengan nama aturan, misalkan ; test

d. Pada opsi “Target Address” di isi dengan IP Address user “192.168.2.51”

e. Opsi “Target Upload” diisi dengan “12k” “Target Download” diisi dengan “12k”

f. Kemudian “Ok”

8. Fungsi pengaturan user untuk servis hotspot.

Servis hotspot adalah salah satu bentuk penyampaian sambungan internet yang

cukup flexible namun membutuhkan pengaturan yang relatif rumit dan detail, salah

satu pembatasan akses yang diterapkan untuk mengatur akses layanan oleh user pada

servis hotspot adalah dengan mengatur ; Username, Password dan bila diperlukan

disertakan juga MAC-Address yang merupakan identitas unik dari setiap perangkat

yang terkoneksi dengan server hotspot.

Untuk melakukan setting pada account user servis hotspot, langkah langkah yang

dilakukan adalah sebagai berikut :

Pilihan menu yang tersedia ;

+ = Menambahkan user hotspot

- = Menghapus user hotspot

X = Menonaktifkan user hotspot

= Mengaktifkan user hotspot

Berikut ini contoh menambahkan user dengan nama : user dan password : password ;

a. Pilih menu “IP” kemudian sub menu “Hotspot”

b. Pilih sub menu “Users”

c. Pilih +

d. Pada opsi “Server” pilih “all”

e. Pada opsi “Name” diisikan nama user “user”

f. Pada opsi “Password” diisikan password user “password”

g. Bila diperlukan dapat juga diisikan MAC Address perangkat user pada opsi

“MAC Address”

h. Pada opsi “Profile” pilih “default”

i. Kemudian “Ok”

Sebagai aturan tambahan dapat disertakan batasan waktu koneksi ke server hotspot,

caranya :

Contoh batas waktu koneksi 30 menit :

a. Pilih dan buka nama user

b. Pilih opsi “Limits”

c. Pada opsi “Limit Uptime” terdapat format waktu 00:00:00 (jam:menit:detik)

d. Isi “00:30:00”

e. Kemudian “Ok”

Detail informasi yang disampaikan diatas adalah informasi dasar yang penting untuk

diketahui oleh Administrator jaringan, yang mencakup pengetahuan untuk mengelola IP

Address, DNS server, Hardware Eternet Router, Firewall, Bandwith Management dan

Hotspot Management.

Fungsi fungsi lain yang bersifat tambahan dan tidak terlalu dibutuhkan dapat

dipelajari dengan memahami terlebih dahulu fungsi fungsi diatas.

Mikrotik block IP mbandel Login Incorect

Mikrotik block IP mbandel Login Incorect
/ ip firewall filter
add chain=input in-interface=public protocol=tcp dst-port=22 src-address-list=ftp_blacklist action=drop

# accept 10 incorrect logins per minute
/ ip firewall filter
add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

#add to blacklist
add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" address-list=blacklist address-list-timeout=3h

=============================================================
kalo kode diatas ini jika dalam 1 menit berusaha 10 kali login (lht script baris kedua, dst-limit=1/1m,9 di login nya yg kesepuluh masuk daftar hitam dan diban selama 3jam, address-list=blacklist address-list-timeout=3h).

kalo mo dibuat range juga bisa portnya tinggal dikasi dst-port=21-23 (utk ftp,ssh,telnet)

setting mikrotik redirect server(Server di Luar Mikrotik)

setting mikrotik redirect server(Server di Luar Mikrotik)
kalo dst-nat itu cuman translasi dari luar (WAN) ke LAN....

nah itu aksi nya.... nah menurut hukum fisika hehehehe kalo ada aksi harus ada reaksi kan?????...........

yang gue tanyain itu reaksi nya kemana?????

kalo aksi nya dst-nat.... harus di kasi reaksi LAN ke WAN (src-nat).

trafficnya (tanpa dst-nat):
wan-----------mikrotik ------------ server
traffic----------->|||

traffic (ada dst-nat):
wan-----------mikrotik----------- server
traffic----------->||| -------------->

nah itu yang udah kamu lakuin sekarang, nah menurut tutor yg gue kasi kemarin ini punya elo sekarang:

wan-------------mikrotik------------- server
..........................||| <---------------traffic

nah si server mo reply ke WAN tapi ga pernah bisa keluar karena ga ditranslasikan/diijinin oleh mikrotik ke WAN

harus di kasi NAT src-nat baru bisa reply dns (alamat web server yang banyak itu ke luar(WANnya).

WAN-------mikrotik------------ Server
<------------|||--------------traffic

semoga ga membuat bingung hehehhe.

ini contoh web punya gue yg udah jadi, coba aja surfing pake browser: http://nytsmg.dyndns.org

daftar di dyndns.com terus di situ di redirect ke ip public gue ^^.

PS:
server gue idup cuman pas jam kerja kantor aja , jadi kalo misalnya pas coba jam 10 maleman kalo error berarti server udah mati.


;;; HTTP Server FEDORA

chain=dstnat dst-address=125.164.20x.xx protocol=tcp dst-port=80
action=dst-nat to-addresses=192.168.2.5 to-ports=80

chain=srcnat dst-address=192.168.2.5 protocol=tcp dst-port=80
action=src-nat to-addresses=125.164.20x.xx to-ports=0-65535

kenapa portnya 0-65535??? karena kita engga tau pasti dikembaliin ke port wan nya pake port brp hheheeh. coba aja pake torch..... port nya engga pasti pake port 80.

untuk server lain sama tinggal di rule nomer 5 ganti aja portnya

PS:
untuk DNS Server lebih baik pake DMZ aja, nih :
http://www.mikrotik.com/testdocs/ros...mz_content.php

;;; Traffic DNS - Mail to SERVER
chain=dstnat dst-address=125.164.20x.xx protocol=tcp dst-port=53
action=dst-nat to-addresses=192.168.2.1 to-ports=53

chain=dstnat protocol=tcp dst-port=25 action=dst-nat
to-addresses=192.168.2.5 to-ports=25

chain=dstnat protocol=tcp dst-port=110 action=dst-nat
to-addresses=192.168.2.5 to-ports=110

Mengamankan Mikrotik Router dengan Firewall-copy

Mengamankan Mikrotik Router dengan Firewall-copy
Mengamankan router mikrotik dari serangan orang orang yang tidak bertanggung jawab, traffic virus dan excess ping, berikut ini langkah-langkah yang harus dilakukan :

Pertama kita buat address-list “trusted-network” yang berisi alamat IP yang berhak mengakses router dan masuk dalam kategori �Trusted Network�.

Dalam contoh berikut ini, saya menggunakan IP lokal network / LAN 192.168.1.0/24. Dan IP public 202.152.x.x dari akses internet rumah saya. Anda bisa menambahkan list IP tersebut agar dapat mengakses routernya.

/ip firewall address-list add list=trusted-network address=192.168.1.0/24 comment=”Trusted Network” disabled=no

/ip firewall address-list add list=trusted-network address=202.152.x.x/24 comment=”Trusted Network” disabled=no

Selanjutnya buat chain virus agar port-port yang sering dimanfaatkan virus di blok sehingga traffic virus tidak dapat dilewatkan, tetapi perlu diperhatikan jika ada user yang kesulitan mengakses service tertentu apakah port yang dibutuhkan user tersebut terblok oleh firewall.

/ip firewall filter add chain=forward connection-state=established action=accept comment=”Allow Established Connections” disabled=no

/ip firewall filter add chain=forward connection-state=related action=accept comment=”Allow Related Connections” disabled=no

/ip firewall filter add chain=virus protocol=udp dst-port=135-139 action=drop comment=”Drop Messenger Worm” disabled=no

/ip firewall filter add chain=forward connection-state=invalid action=drop comment=”Drop Invalid Connections” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=135-139 action=drop comment=”Drop Blaster Worm” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment=”Worm” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=445 action=drop comment=”Drop Blaster Worm” disabled=no

/ip firewall filter add chain=virus protocol=udp dst-port=445 action=drop comment=”Drop Blaster Worm” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=593 action=drop comment=”________” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=”________” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1080 action=drop comment=”Drop MyDoom” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1214 action=drop comment=”________” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1363 action=drop comment=”NDM Requester” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1364 action=drop comment=”NDM Server” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1368 action=drop comment=”Screen Cast” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1373 action=drop comment=”Hromgrafx” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=1377 action=drop comment=”Cichlid” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Bagle Virus” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=2283 action=drop comment=”Drop Dumaru.Y” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=2535 action=drop comment=”Drop Beagle” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Drop Beagle.C-K” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=3127 action=drop comment=”Drop MyDoom” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=3410 action=drop comment=”Drop Backdoor OptixPro” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=4444 action=drop comment=”Worm” disabled=no

/ip firewall filter add chain=virus protocol=udp dst-port=4444 action=drop comment=”Worm” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=5554 action=drop comment=”Drop Sasser” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=8866 action=drop comment=”Drop Beagle.B” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=9898 action=drop comment=”Drop Dabber.A-B” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=10000 action=drop comment=”Drop Dumaru.Y, sebaiknya disable karena juga sering digunakan utk vpn / webmin” disabled=yes

/ip firewall filter add chain=virus protocol=tcp dst-port=10080 action=drop comment=”Drop MyDoom.B” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=12345 action=drop comment=”Drop NetBus” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=17300 action=drop comment=”Drop Kuang2″ disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=27374 action=drop comment=”Drop SubSeven” disabled=no

/ip firewall filter add chain=virus protocol=tcp dst-port=65506 action=drop comment=”Drop PhatBot, Agobot, Gaobot” disabled=no

Jump semua paket yang melewati router ke dalam virus chain

/ip firewall filter add chain=forward action=jump jump-target=virus comment=”Jump to The Virus Chain” disabled=no

Accept Established and Related Connection

/ip firewall filter add chain=input connection-state=established action=accept comment=”Accept Established Connections” disabled=no

/ip firewall filter add chain=input connection-state=related action=accept comment=”Accept Related Connections” disabled=no

Drop Invalid Connection

/ip firewall filter add chain=input connection-state=invalid action=drop comment=”Drop Invalid Connections” disabled=no

Accept UDP Connection, Limited Pings and Drop Excess Ping

/ip firewall filter add chain=input protocol=udp action=accept comment=”UDP” disabled=no

/ip firewall filter add chain=input protocol=icmp limit=50/5s,2 action=accept comment=”Allow Limited Pings” disabled=no

/ip firewall filter add chain=input protocol=icmp action=drop comment=”Drop Excess Pings” disabled=no

Allow Input Connection From Trusted Networks

/ip firewall filter add chain=input protocol=tcp dst-port=21 src-address-list=trusted-network action=accept comment=”FTP” disabled=no

/ip firewall filter add chain=input protocol=tcp dst-port=22 src-address-list=trusted-network action=accept comment=”SSH for Secure Shell” disabled=no

/ip firewall filter add chain=input protocol=tcp dst-port=23 src-address-list=trusted-network action=accept comment=”Telnet” disabled=no

/ip firewall filter add chain=input protocol=tcp dst-port=80 src-address-list=trusted-network action=accept comment=”Web” disabled=no

/ip firewall filter add chain=input protocol=tcp dst-port=8291 src-address-list=trusted-network action=accept comment=”Winbox” disabled=no

/ip firewall filter add chain=input protocol=tcp dst-port=1723 action=accept comment=”pptp-server” disabled=no

/ip firewall filter add chain=input src-address-list=trusted-network action=accept comment=”From Trusted Network” disabled=no

Log All and Drop Everything Else

/ip firewall filter add chain=input action=log log-prefix=”DROP INPUT” comment=”Log Everything Else” disabled=no

/ip firewall filter add chain=input action=drop comment=”Drop Everything Else” disabled=no

Dengan Firewall diatas maka :

  1. Router hanya dapat diakses service FTP, SSH, Web dan Winbox dari IP yang telah didefinisikan dalam address-list “trusted-network”.
  2. Port-port yang sering dimanfaatkan oleh virus di blok oleh Router sehingga traffic virus tidak dapat melewati Router, tetapi perlu diperhatikan jika ada user yang mengakses service tertentu harus dicek pada chain=”virus” apakah port yang dibutuhkan user tersebut terblok oleh firewall atau tidak.
  3. Ping Request dibatasi untuk menghindari excess ping.

NB : Perlu diperhatikan bahwa default user dari mikrotik ini adalah admin. Untuk lebih safe nya, buat user baru dan password dengan group full kemudian disable user admin, hal ini untuk meminimasi resiko router mikrotik di hack orang.

Os XP di Acer Aspire 4310

Os XP di Acer Aspire 4310

Notebook acer yang satu ini memang bikin kepala mumet alias pusing, mungkin sebagian dari anda adalah pemilik barang yang satu ini, acer 4310 yang kisaran harganya sekitar 8.000.000 ini memiliki Operating System Linux sebagai Basic Edition nya, kalo dah masuk di indonesia sih sudah di daur ulang ke Os Vista. mungkin karena microsoft lebih familiar kali ya di kalangan pengguna komputer yang cuman sekedar ngetik ngetik aja.

as4310.jpg

Nah saya ada pengalaman gimana caranya merubah Acer Aspire 4310 dari Os Vista ke Os Xp, sebelum kita membahas migrasinya Aspire 4310 anda harus tau kalo kita pakai Os Vista mungkin kalo Notebook atau PC Tablet kita tidak sanggup untuk menjalankannya karena mungkin pengoperasiannya akan sangat lambat. “secara grafis dan tampilan sih Vista lebih o.k lah.. tapi kalo prosesi kerja jadi lambat kan jadi nggak asik tuh.. ya mending pake xp ajalah.. “

Ketika ingin melakukan migrasi ke XP awalnya sih saya beranggapan itu hal biasa, karena untuk melakukan instal ulang kan syaratnya gampang, cuma bermodalkan CD Os XP dan ngerti lah sedikit sedikit prosedurnya. Teryata lain halnya di kalo Acer Aspire 4310 yang nota bene memiliki hardisk model sata.

Pengalaman pertama kali nyoba peng-Instalan os XP saya kaget sih.. aneh dan campur curiga lah.. karena pas saat peng-Instalan hardis gak ke detek sama sekali alias gak bisa dibaca.. takut sih iya.. jangan jangan notebooknya yang rusak.., yaaa akhirnya coba lagi.. “eeh ternyata masih tetap gak bisa ke detek.. korek korek sampai kepala pusing gara gara gagal terus pas nginstal nya akhirnya saya coba ganti sama Os lain.. waktu itu saya coba pakai Os nya Linux yang Igos Nusantara punya, “.. eh ko ini bisa ya.. trus coba lagi ke Os Xp dan ternyata masih sama aja.. teatap aja hardisk gak ke detek juga.. “

Saat itu sih saya berpikiran kalo Cd Os XP nya yang rusak.. wah sayang sekali padahal Cd nya yang Ori.. trus saya coba CD XP yang lain.. “eeeh teryata memang gak bisa juga.. “

Yaa kira kira 2 hari lah mikirin Notebook Acer Aspire 4310 yang bikin pusing ini.. ahkirnya dengan sedikit rasa ingin tahuan yang tinggi saya coba Browsing di internet siapa tau aja ada orang lain yang mengalami hal yang sama seperti yang saya alami.. , setelah saya browsing.. “eeh ternyata memang banyak yang mengeluh sama apire 4310, bukan lantaran produknya tidak bagus, tetapi karna ingin melakukan migrasi ke XP memang sedikit bermasalah pada driver satanya..

Hari ketiga saya coba kontak mas adi ayahnya aksa kenalnya sih pas nge net juga setelah baca blognya mas adi. nah disitu ( di blognya mas adi ) ada sedikit pencerahan bagaimana menginstal Os XP di Acer Aspire 4310.. “Ck.. ck.. ck.. ternyata mesti ada prosedur lain toh.. karena keingin tahuan saya yang tinggi dan dibantu sama mas adi akhirnya saya coba trik untuk penginstalan nya, dan yesss!!! akhirnya saya gagal… ” ha ha ha mungkin saya nya yang sedikit o-on .. dan karena rasa penasaran dan keingin tahuan yang tinggi ( he he semangat bener…” ) akhirnya saya coba terus.. ” ilmu kan gak akan kita dapat kalo tidak digali.. ” gimana ? setuju nggak ?..

Yesss!!! ternyata kegagalan bukan lah hambatan.. akhirnya saya berhasil.. terima kasih mas adi atas bimbingannya.. berikut ini saya tulis apa yang sudah saya lakukan..

langkah2nya:

siapkan dulu:
1 - CD windows XP
2 - nlite http://www.nliteos.com/download.html
3 - SATA Driver http://rapidshare.com/files/42244341/SATA_Raid.rar.html
4 - CD Kosong (lebih bagus gunakan CDRW, karena bisa digunakan kembali ketika terjadi kesalahan)cara-cara:

1 - Buat folder baru

2 - masukkan CD WINXP

3 - buat folder baru dan kopi semua isi CD Win XP ke dalam folder tersebut

4 - jalankan Program nlite yang sudah di instal tadi

- cari folder yang isinya CD/DVD yang berisi CD WINXP

- pilih destinasi yg sesuai untuk WINXP - contoh: C:\CDXP
1.jpg
- mulai proses penyalinan

3 - extract SATA DRIVER yang sudah di download tadi

4 - cari: iastor.ini ( kalo di komputer saya dibacanya inf trus saya klik kanan pilih properti dan ganti extensien nya menjadi format ini )

5 - masukkan salinan fail tersebut ke C:\XPCD\I386

- buka folder C:\CDXP\I386 dan cari: TXTSETUP.SIF

-buka file yang menggunakan program : notepad
- cari file: [SourceDisksFiles]

- masukkan: iastor.ini = 1,,,,,,_x,4,1
- cari file : [HardwareIdsDatabase]
- masukkan: PCI\VEN_8086&DEV_27C5&CC_0106 = “iaStor”
- cari file : [SCSI.Load]
- masukkan: iastor = iastor.ini,4
- cari file : [SCSI]
- masukkan: iastor = “Intel� 82801GBM SATA AHCI Controller (Mobile ICH7M/DH)”
5 - SAVE TXTSETUP.SIF

6 - kembali ke nlite: sesudah anda selesai semua langkah2 di atas, tekan next atau lanjut hingga bertemu ini:
2.jpg

7 - setelah memilih “option” di atas, teruskan ke:
3.jpg
8 - anda boleh membakar CD anda sekarang

9 - sekarang anda sudah siap melakukan instalasi ke Windows XP

tambahan lagi, driver bawaan acer adalah windows vista. beberapa drivernya sih compatible dengan winXP yang saya instal. untuk masalah ini jangan kuatir, silahkan lakukan prosedur dibawah ini.

Instal Audio Driver:
http://support.acer-euro.com/drivers/notebook/tm_3270.html
cari: Audio Driver 5.10.0.5273

1 - masuk ke device manager ” clik kanan my computer > properties > hardware > device manager”
2 - cari pci device dengan tanda bewarna kuning
3 - klik kanan dan instal driver
4 - tujukan ke folder dimana driver untuk audio di atas di extract kan
5 - kalo sudah restart notebooknya

Instal WLAN:
http://www.acer.com.cn/driver/download.asp…ss_Broadcom.zip

1 - extract fail yg didownload
2 - uninstal semua driver wlan
3 - masuk ke device manager ” klik kanan my computer > properties > hardware > device manager”
4 - klik kanan pada “Broadcom 802.11g Network Controller” ATAU network controller
5 - pilih: update driver
6 - pilih: install from a list or a spesific location
7 - pilih: dont search i will choose the driver to install
8 - pilih: have disk
9 - pilih: browse
10-ader satu pilihan aja driver, pilih yg itu
11-abaikan msg yg kluar: pilih YES - Siap!!!

“selamat Mencoba……”

NAT_DHCP_Firewall

NAT_DHCP_Firewall
NAT_DHCP_Firewall

settingan NAT , DHCP, n Firewall (iptable) di ubuntu 7.10 server..


Setting EtherNet Card n NAT

1. edit file di /etc/network/interface
# nano /etc/network/interface

contoh isinya
#————————————-
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.16.200
netmask 255.255.255.0
network 1192.168.16.0
broadcast 192.168.16.255
gateway 192.168.16.254
nameserver 192.168.16.253

auto eth1
iface eth1 inet static
address 10.10.10.200
netmask 255.255.255.0
network 10.10.10.0
broadcast 10.10.10.255
#————————————-

2. Enable IP Fordwarding
#echo 1 > /proc/sys/net/ipv4/ip_forward

3. Routing Network
# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

4. Restart The Network
# /etc/init.d/networking restart

buat dhcp
1. install paket dhcp
# apt-get install dhcp3-server
2. konfigurasi file /etc/dhcp3/dhcpd.conf
# nano /etc/dhcp3/dhcpd.conf
3. tambahkan baris-baris berikut
#————————————-
subnet 10.10.10.0 netmask 255.255.255.0 {
range 10.10.10.50 10.10.10.199;
option routers 10.10.10.200;
option domain-name-servers 192.168.16.253;
}
#————————————-
4. restart daemon dhcpd
# /etc/init.d/dhcp3-server restart

buat Aturan IpTables (firewall)
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -d 192.168.3.5 -j ACCEPT
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -d 10.10.10.200 -j ACCEPT
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -d 192.168.16.200 -j ACCEPT
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -d 192.168.16.254 -j ACCEPT
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -d 192.168.16.253 -j ACCEPT
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -d 10.10.10.253 -j ACCEPT
# iptables -t nat -A PREROUTING -s 10.10.10.0/24 -j DROP

buat matiin internet na
# iptables -t nat -I PREROUTING -s 10.10.10.0/24 -d 192.168.3.5 -j DROP

Konek Inet Via HP

Konek Inet Via HP
konek internet di mac mic mac pke hape [kabel data version]
Taw caranya konek internet di mac mic mac pke kabel data?
(ya pke hape nya juga maksudnya..)
gini caranya..

colokin kabel nya ke hape trus colokin ke Mac lo
klo dah ke detect si Mac berarti dah siap tempur!
eh iya jangan lupa dipastikan hape Lo dah di setting siap buat interetan
coba cek di
Menu > Settings >Connectivity >Internet settings > Internet profiles > [pilih koneksi nya]
oke beibe, skarang kembali ke latop!
check this out!
System preferences > Network > Assist Me
coz mo konek pke kabel so pilih "USB cable"
beres?
coba jalanin browser nya.. bisa kan?
anjriit.. gampang bgt!
Posted by andr3licious at 22:44 0 comments
konek internet di mac mic mac pke hape [blutut version]
Ada yang request nih suruh posting setting modem hp di mac biar bisa konek internet gtu.. hayoo siapa ngaku!
berhubung lagi baik, gw publish nih..
tulisan ini menghabiskan satu bungkus pecel lele nasi uduk plus segelas air puith =D

ga penting ya? langsung aja deh!
siapin dulu mekbuk yang nyala n bisa dipake normal
hape sendiri yang bisa gprs (jng minjem! malu maluiin), ada pulsa nya n bisa djadiin modem
sebungkus pecel lele nasi uduk, klo mo ngikut gw
segelas air putih.. jaga-jaga klo dehidrasi sediain satu galon air mineral yang bukan isi ulang!
minta doa restu orang yang dicintai..
yup..
klo udah kita mulai!

1. Buka system preferences>bluetooth>devices>set up new device
2. Setelah blutut setup assistan nongol klik continue
3. Pilih device yang mo lo di konek ke mac, in this part klik mobile phone yak! then continue..
4. System bakal scan bluetooth device yang ada disekitar.. klo dah ktemu blutut lo then pilih n continue
5. System akan mencoba konek ke hape lo.. so klik continue
6. Akan muncul angka togel dsana.. jangan bingung, liat hape lo, pasti ada konfirmasi buat pairing, masukin angka togel tersebut ke hape n lanjut..
7. Nah disini akan keliatan fasilitas apa aja yg bisa dilakukan kedua belah pihak. (kayak mo ijab kabul aja nih..) Yang paling penting disini adalah kasih check di "Access the internet.." trus pilih yang "uses a direct.." yang lain kosongin aja deh check box nya biar ga bingung.
8. Oke, skarang ada beberapa kolom yang harus diisi, such as.. user name, password, GPRS CID string, ama modem script. user name ama password diisi sesuai operator kartu lo.. modem script dipiih yang sesuai ama hp lo..
dalam test ini gw pke "Sony Ericsson 3G CID1" buat merk ato seri lain bisa klik disini
oh iya check box yang dibawah di check smua yak! klo udah klik continue!
9. Conclusion.. klo congratulation berarti smua nya dah kelar! klik quit!
10. Oke bro skarang buka lagi system preference>network>bluetooth>connect
(ato buka shortcut di system tray icon diatas kanan, klik gambar wifi yang
kayak potongan pizza itu trus klik "open internet connection", then pilih i
icon bluetooth.. klo udah klik connect!) huff.. kyknya simple yang
pertama yak? tp klo dah praktek enakan cara yang kedua kok.. ga
percaya? awas lo!

Udah bisa konek kan bro?
FYI aja.. lagi asyik pke IM3 nih. Knapa? Murah meriah mo yg Rp 100/menit ato Rp 1/kB tetep murah! Pinter-pinter aja gunain nya..

Jadi gini perhitungannya..

1. Klo yang time base ato Rp 100/menit kan berarti Rp 6000/jam tp mo download segede apa juga biayanya segitu! kLo misalnya nih menurut pengalaman, speed download nya 15kbps berarti sejam lo bs dapet file 15kb x 60dtk x 60 menit = 54.ooo kB = 54mB.

2. Bandingin klo pke volume base yg Rp 1/kB.. file segede 54Mb atau 54.ooo kB harus kamu tebus dengan pulsa 54.ooo alamaaaaak!
Eits tp tunggu dulu, klo kamu cuma mo chatting ato ber YM alangkah murah nya klo pake yang volume base ini! Anggap aja kamu sejam chatting cm abis 2 mB, berati lo cuma buang pulsa 2000 doank hehe.. ngirit cing!

Nah.. skarang pengen tau ga cara milih mo pke time base ato vulume base? Gampang.. cuma username n passwordya doank kok yang perlu diganti..

Time Base :
Username : indosat@durasi
Password : indosat@durasi

Volume Base
Username : gprs
Password : im3

Oke sodara sodara, selamat mencoba selamat berjuang! NO PAIN NO GAIN!
YNWA!

Daftar korban percobaan..
1. mekbuk putih yang dah agak kusam
2. soner k800i yang kucinta
3. pecel lele nasi uduk
4. pulsa.. (modal doonk!)