Script dan Scheduller Mikrotik

Script dan Scheduller Mikrotik

Memberikan Batasan Akses Lewat Scheduller yang menjalankan script sesuai waktu yang ditentukan

Test case : facebook limiter

Membatasi pengaksesan facebook pada jam tertentu

Memberikan setting waktu yang tepat sesuai dengan daerah, setting NTP (Network Time Protocol) supaya script dijalankan tepat sesuai dengan waktu yang telah ditentukan :

/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes;

Memberikan aturan blokir facebook

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dst-port=80 content="facebook" action=drop comment="Blokir Akses Facebook";

Buat script dengan aturan, cari content yang berisi “facebook” dan rubah aturan disable dari aturan itu

/system script add name="fb-allow" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes}

/system script add name="fb-deny" policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}

/system script add name="fb-holiday" policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=yes]}

Buat scheduler

/system scheduler add name="fb-08:00" start-date=jan/01/1970 start-time=08:00:00 interval=1d on-event="fb-deny"

/system scheduler add name="fb-12:00" start-date=jan/01/1970 start-time=12:00:00 interval=1d on-event="fb-allow”

/system scheduler add name="fb-13:00" start-date=jan/01/1970 start-time=13:00:00 interval=1d on-event="fb-deny"

/system scheduler add name="fb-14:00" start-date=jan/01/1970 start-time=14:00:00 interval=1d on-event="fb-allow"

/system scheduler add name="fb-minggu" start-date=oct/25/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

/system scheduler add name="fb-senin" start-date=oct/26/2009 start-time=00:00:00 interval=7d on-event="fb-holiday"

Teknik Dasar Mengirim SMS dengan Gammu - [gammu-smsd-inject]

Teknik Dasar Mengirim SMS dengan Gammu - [gammu-smsd-inject]

Pada artikel sebelumnya, saya sudah paparkan bagaimana cara melakukan setting Gammu untuk SMS Gateway yang diintegrasikan dengan MySQL. Jika proses setting ini sudah beres, maka selanjutnya kita bisa bermain-main sepuasnya dengan Gammu.

Dalam artikel ini saya akan paparkan bagaimana teknik dasar mengirim SMS dengan Gammu baik dalam bentuk short text maupun long text. Pada bagian akhir nanti kita akan coba membuat script sederhana dengan PHP untuk mengirim pesan SMS ini yang diintegrasikan dengan Gammu melalui sebuah form.

OK.. pada dasarnya dengan Gammu kita bisa mengirim pesan SMS dalam 2 cara yaitu dengan menggunakan command inject yang sudah disediakan oleh Gammu, atau cara kedua kita menyisipkan record dengan menggunakan query SQL ke dalam tabel ‘outbox‘. Bila Anda ingin mengirimkan pesan dengan cara yang kedua ini, terlebih dahulu Anda harus sudah memiliki database ‘sms’ dan tabel-tabel yang diperlukan oleh Gammu sebagaimana sudah saya jelaskan cara instalasinya pada langkah ke-5 dari artikel sebelumnya.

Untuk cara pertama yaitu dengan menggunakan command inject yang disediakan oleh Gammu, caranya adalah masuklah ke folder/direktori Gammu Anda melalui Command Prompt di mana terdapat file bernama ‘gammu-smsd-inject‘, lalu ketikkan perintah berikut ini kemudian tekan ENTER.

1.gammu-smsd-inject -c pathtoconfigfile TEXT notujuan -text "pesan"

dengan parameter ‘pathtoconfigfile‘ adalah path direktori file ‘SMSDRC’ Gammu Anda.

Sebagai contoh misalkan akan dikirim pesan SMS ke no. tujuan +62811000001 dengan pesan “Hello World”, dan file SMSDRC nya terletak di C:\gammu, maka perintahnya

1.gammu-smsd-inject -c c:\gammu\smsdrc TEXT +62811000001 -text "Hello World"

Keterangan: tanda petik ganda pada command inject digunakan untuk mengapit string pesan yang akan dikirim.

Perintah di atas akan mengirimkan pesan SMS dengan maksimum panjang karakternya adalah 160.

Lantas, bagaimana jika untuk long text atau dengan panjang yang lebih dari itu? Caranya adalah dengan menggunakan pesan dalam format EMS.

1.gammu-smsd-inject -c pathtoconfigfile EMS notujuan -text "pesan"

Setelah Anda mengetikkan perintah di atas, maka Gammu akan segera mengirim SMS ke nomor tujuan.

Selanjutnya kita gunakan cara kedua, yaitu dengan menyisipkan sebuah record ke dalam tabel ‘outbox’.

Di dalam tabel ‘outbox‘ Anda akan lihat banyak sekali field, namun yang perlu diperhatikan hanyalah field ‘DestinationNumber‘ dan ‘TextDecoded‘. Field ‘DestinationNumber’ itu nanti akan diisi dengan nomor HP tujuan dan ‘TextDecoded’ diisi dengan pesan SMS yang akan dikirimkan.

Contoh:

1.INSERT INTO outbox(DestinationNumber, TextDecoded) VALUES ('+62811000001', 'Hello World');

Nah… cara ini hanya hanya akan bisa dilakukan bila pesan teks SMS nya maksimal 160 karakter saja. Sedangkan bila lebih dari itu tidak bisa. Meskipun di situs resminya Gammu telah menjelaskan teknik mengirim SMS long text melalui INSERT tabel menggunakan multipart, namun setelah saya coba berkali-kali dan berhari-hari ternyata tidak bisa dilakukan. Sehingga untuk mengirim long text (di atas 160 karakter) sebaiknya gunakan command inject di atas.

OK.. sekarang kita akan mencoba membuat script PHP sederhana untuk mengirim pesan SMS yang terintegrasi dengan Gammu ini.

Langkah pertama kita buat form untuk mengirim pesan SMS nya terlebih dahulu.

1.<form method="post" action="send.php">
2.No. HP Tujuan : <input type="text" name="nohp" value="+62"><br>
3.Pesan : <textarea name="msg">textarea><br>
4.<input type="submit" name="submit" value="Kirim SMS">
5.form>

Langkah kedua, kita buat script php untuk mengirim pesannya.

send.php

1.
2.$noTujuan = $_POST['nohp'];
3.$message = $_POST['msg'];
4.
5.exec('c:\gammu\gammu-smsd-inject.exe -c c:\gammu\smsdrc EMS '.$noTujuan.' -text "'.$message.'"');
6.
7.?>

Perintah exec() dalam PHP digunakan untuk menjalankan perintah command DOS dalam hal ini adalah perintah command inject nya Gammu.

Karena command inject Gammu pada script di atas menggunakan format EMS maka memungkinkan kita mengirim SMS dengan jumlah karakter lebih dari 160 buah.

Oya… sebelum Anda menjalankan script di atas, pastikan bahwa service Gammu nya telah Anda jalankan, dan HP Anda tercolok ke PC :-)

Sekarang… bagaimana bila pengiriman SMS dari script di atas menggunakan query INSERT? Ini dia scriptnya.

send.php

01.
02.mysql_connect("dbhost", "dbuser", "dbpass");
03.mysql_select_db("sms");
04.
05.$noTujuan = $_POST['nohp'];
06.$message = $_POST['msg'];
07.
08.$query = "INSERT INTO outbox (DestinationNumber, TextDecoded) VALUES ('$noTujuan', '$message')";
09.$hasil = mysql_query($query);
10.if ($hasil) echo "SMS berhasil dikirim";
11.else echo "SMS gagal dikirim";
12.
13.?>

Teknik pengiriman SMS di atas sudah diuji coba dan berjalan dengan lancar di modem Wavecom Fastrack.

Bagaimana mudah bukan membuatnya? Nantikan artikel berikutnya tentang cara pengolahan SMS yang masuk dengan studi kasus autorespon atau autoreply.

Sebagai catatan, baik cara pertama maupun cara kedua, bila pesan SMS sudah terkirim maka secara otomatis akan tersimpan ke dalam tabel ‘sentitems’ dalam database ‘sms’.

Update:
Oya, satu lagi… teknik di atas merupakan teknik pengiriman sms untuk Gammu versi mulai 1.25 sampai dengan terbaru. Untuk versi Gammu di bawah 1.25 kemungkinan ada sedikit perbedaan perintah.


Ref : http://blog.rosihanari.net/teknik-dasar-mengirim-sms-dengan-gammu

SMS Gateway menggunakan Gammu di Ubuntu

SMS Gateway menggunakan Gammu di Ubuntu
Gammu adalah software opensource yang cukup handal untuk membangun SMS gateway. pada penerapannya, bisa dikembangkan menjadi berbagai macam aplikasi terapan seperti untuk pooling SMS, server pengisian pulsa dan sebagainya. Konsep dan cara kerja gammu sangat sederhana. Gammu melakukan koneksi ke HP. membaca SMS yang ada di handphone mengambilnya, dan menyimpannya ke dalam media penyimpanan di komputer. baik itu berupa file text atau ke dalam database seperti MySQL ataupun PostgreSQL.
Pada percobaan ini, saya menggunakan HP siemens M55 dengan kabel konektor BlueTech USB.
skema..

[hahdphone] <-> [gammu] <-> [Database Mysql] <-> [Intefaces]

Installasi Gammu
gammu dapat di download di website resminya di sini
http://dl.cihar.com/gammu/releases/gammu-1.27.92.tar.gz
Download gammu
#wget http://dl.cihar.com/gammu/releases/gammu-1.27.92.tar.gz
Extract hasil download

#tar -zxfv gammu-1.27.92.tar.gz

masuk ke direktori hasil extract
cd gammu-1.27.92
Sebelum melakukan proses kompilasi, pastikan bahwa cmake, gcc dan library mysql-devel sudah terinstall. cmake untuk proses kompilasi sedangkan mysql-devel digunakan supaya gammu dapat menyimpan SMS ke dalam database mysql.

#apt-get install cmake gcc
#apt-get install libmysql++-dev

Lakukan installasi dengan 3 langkah mudah

#./configure --enable-shared
#make
#make test
#make install

Setelah terinstall, kita coba mengkonfigurasi gammu supaya dapat berkomunikasi dengan handphone

# gammu-config
Current Gammu configuration
?
? ?
? P Port (/dev/ttyUSB0) ?
? C Connection (at19200) ?
? M Model () ?
? D Synchronize time (yes) ?
? F Log file () ?
? O Log format (nothing) ?
? L Use locking () ?
? G Gammu localisation () ?
? H Help ?
? S Save ?
? ?
? ?
? |

Pilih menu Port dan ganti dengan /dev/ttyUSB0 karena kabel yang saya gunakan menggunakan port usb ke komputer
Untuk Connection pilih at19200. ini merupakan tipe koneksi default. jika anda menggunakan jenis HP yang berbeda, silahkan sesuaikan.
Pilih menu Save kemudian OK
pada dasarnya, yang kita lakukan tadi adalah menciptakan sebuah file yang disimpan dalam home direktori user dengan nama .gammurc
silahkan cek isi file tersebut.
Test koneksi ke HP dengan gammu

# gammu --identify
Device : /dev/ttyUSB0
Manufacturer : Siemens
Model : unknown (M55)
Firmware : 10
IMEI : 352027003098230
SIM IMSI : 510102833201906

Konfigurasi SMS daemon menggunakan database mysql
1. Buat database dengan nama sms

#mysqladmin create sms -uroot -p
#mysql sms -uroot -p < /usr/local/share/doc/gammu/examples/sql/mysql.sql

2. Membuat konfigurasi smsd. Gammu sudah membuatkan contoh konfigurasi file untuk smsd. kita bisa mengambilnya dari file /usr/local/share/doc/gammu/examples/config/smsrc. yang perlu kita lakukan adalah dengan mengcopy file tersebut dan simpan dalam direktori /etc

#cp /usr/local/share/doc/gammu/examples/config/smsdrc /etc

3. Edit file /etc/smsdrc dan rubah pada bagian berikut

[gammu]
port = /dev/ttyUSB0
connection = at19200
[smsd]
service = mysql
user = root
password = rahasia
pc = localhost
database = sms

4. Menjalankan Gammu sebagai SMS daemon

# gammu-smsd -c /etc/smsdrc

Setelah menjalankan perintah di atas, gammu akan mulai bekerja. membaca sms di HP kemudian menyimpannya ke dalam database MySQL dan menghapus SMS yang ada di HP. coba cek inbox HP. jika SMSnya berkurang, berarti gammu sudah berjalan dengan benar. jika tidak, silahkan periksa file smsdlog
Membaca dan mengirim SMS
untuk membaca SMS, kita dapat melakukan query pada tabel inbox di dalam database sms

mysql> select * from inbox;

Sedangkan jika ingin mengirimkan SMS, dapat dilakukan dengan menginputkan tabel outbox

mysql> insert into outbox(DestinationNumber,TextDecoded) values('081328080020','Test sms gammu');

Jadi, untuk mengelola SMS, baik untuk mengirimkan atau membaca SMS yang masuk tinggal mengutak-atik tabel-tabel yang ada di database sms. karena sudah disimpan dalam database, kita dapat membuat interface dengan menggunakan PHP,VisualBasic, Delphi, Java atau apapun sepanjang dapat mengakses database MySQL.
Terima kasih, dan selamat mencoba


Ref : http://taujago.web.id/index.php/2010/03/05/sms-gateway-menggunakan-gammu-di-ubuntu/

Opensourc SMS Gateway Using Gammu and MySQL

Opensourc SMS Gateway Using Gammu and MySQL

The applications of the SMS gateway can be searched and downloaded from the internet. You would be able to found a number of SMS gateway applications from the various platforms.

One of them that will be discussed in this article is Gammu, As we are going to use Gammu application for sms gateway, because apart from we can download free also it’s easy to configure and can be use in both i.e. Windows and Linux. Another reason is to use Gammu is because MySQL can be used. But here we will discuss that how we can setup SMS gateway using Gammu with Linux.
.
The mobile phone that succeeded in being tried by me is Nokia 3310 and Siemens C35i using Linux platform.

Before installation is done, first read information repeatedly about Gammu here:

http://www.mwiacek.com/gsm/soft/gammu.html

Have you gathered the information?
OK.
.Now let’s gather the requirement to develop the SMS Gateway using Gammu.

Download Gammu.

1. gammu.tar.gz
Download the gammu package from: www.mwiacek.com/zips/gsm/gammu/gammu.tar.gz

# wget www.mwiacek.com/zips/gsm/gammu/gammu.tar.gz

2. Web Server (If you have webserver, don’t ignore this, if not yet then you must install first apache, myslq, php)

3. The Nokia mobile phone 3310 or Siemens C35i. For other mobiles phone please read again:

http://www.mwiacek.com/gsm/soft/gammu.html

Gammu supports various types of the mobile phones. How come? look this: Gammu currently supports: majority of Nokia phones from DCT3 generation with Nokia operating system – for example Nokia 3210, 3310, 3315, 3410, 5110, 5130, 6110, 6510, 6610, 7210, 8310
Many AT devices – for example many Siemens, Sony Ericsson, Nokia, Alcatel models, Alcatel from BE5/BF5/BH4 generation – for example 501, 511, 512, also some functions with OBEX and Symbian devices

4. The Serial cable for the mobile phone

If you have successfully downloaded gammu.tar.gz, please extract it:

#tar xvfz gammu.tar.gz

After extracted automatically you will find the folder gammu-1.08.00, now enter into the extracted folder.

#cd gammu-1.08.00

Before installation make a custom read README, INSTALL, etc.

#. /configure

#make

Here must be paid attention by you whether being that error or not if the error occurs that means a significant library mysql you are still being more incomplete, usually an error that appear was found when MySql doesn’t support the gammu. (his installation process repeatedly try to find the mysql library which is needed)

#make shared
#make install
#make installshared

Further it’s necessary for you to upgrade the “library”

# vi/etc/ld.so.conf
Add the library link /usr/local/lib to file ld.so.conf, once you have done upgrade the library:

#/sbin/ldconfig

Note: If you did not find any error to this stage means you have successfully installed the Gammu sms Gateway.

Now tried to enter again into the folder where you extracted gammu.tar.gz and copy the available files in folder /docs/example/config/* here you will find 3 files by the name of gammurc, mysql.sql, smsdrc and gammurc.

Copy the gammurc and smsdrc into the /etc directory

#cp gammurc smsdrc /etc/

Further search edited file like this:

[gammu]
port = /dev/ttyS0 #if you are using COM2 then substitute it with ttyS1
#model = 6110 #model of mobile phone was ignored by you, because it doesn’t need often to mention the phone model.
connection = fbus #With Nokia mobile phone connection should be fbus if you used the Siemens mobile phone then substitute the fbus with at19200
#synchronizetime = yes
#logfile = gammulog
#logformat = textall
#use locking = yes
#gammuloc = locfile
#startinfo = yes
#gammucoding = utf8
#rsslevel = teststable
#usephonedb = yes

If you are still confused, inside the gammurc file it has the guidance available. If you are lazy to edit the file, then you can get the file from www.posmetropadang.com/gammu/gammurc

Now confirm if the data cable and your mobile phone are connected to port COM1 to your computer, if everything is just fine, run the following command.

#gammu –identify

I hope you could see output as being supervised here:

Manufacturer : Nokia
Model : 3310 (NHM-5)
Firmware : 06.33 F (28-11-03)
Hardware : 1012
IMEI : 350835608671298
Original IMEI : 350835608671298
Manufactured : 0802
Product code : 0505201
Simlock 1 : MCC+MNC 00101, opened, user , counter 0
Simlock 2 : GID1 0000, opened, factory, counter 0
Simlock 3 : GID2 0000, opened, factory, counter 0
Simlock 4 : MSIN 0000000001, opened, factory, counter 0
MSID : 830d50880846870ebedd126096
MCU checksum : 9C79
DSP ROM : 6

If you got the connection info like above gammu means Gammu detected your mobile phone and now you can continue to the next step.

Now let’s configure that how all the phone’s SMS’s will be kept by MySQL database to put forward on the webpage using php scripts.

OK further bro… our work has almost finished, possibly have some coffee or cigarettes that could disrupted previously hehe…??

Now try to open the file smsdrc that you copied earlier to directory /etc

#vi /etc/smsdrc

[smsd]
PIN = 1234
logfile = smsdlog
commtimeout = 1
sendtimeout = 10

Search and edit the part that you configured in the mysql database:

# ————————- SETTINGS FOR –smsd MYSQL —————————
user = root
password = password_mysql_user
pc = localhost
database = Database_name

Note: The above lines are to make connection with mysql database.

Now enter to the directory /docs/example/config/ and get the file ‘mysql.Sql’, that is a table structure. Now put this file to the database that we are creating in the MySQL database for SMS gateway.

For sms database
#mysqladmin –u root –p create sms

To create tables for gammu grab the file ‘mysql.sql’

#mysql –u root –p <>

Or it can be easier for you if you make Gammu tables through phpadmin.

http://localhost/phpmyadmin

Once you are finished, you can start the smsd deamon:

#gammu –smsd MYSQL/etc/smsdrc

The Log filename Is “smsdlog”
Press Ctrl+C to stopped the program …

After the issuing above command if output is like above means your SMS gateway is done successfully and you can use it according to your requirements. And all the available sms in your mobile phone will be entered inside the mysql database.

For your further stage is to putting forward your SMS’s to the web which is using php scripts, The required php script can be downloaded from

http://www.syednetworks.com/gammu-sms-gateway.zip

You must edit the SMS database info in the sms.php file.
If all goes well, now you can open the SMS’s through your favorite browser:

http://localhost/sms.php

Now what must be done by you??
The smsd service deamon must be running to grab the SMS’s from the phone and you and you could see on the web.

Create a Gammu startup script.sh and place it in the directory /usr/local/Bin/#cd/usr/local/bin/

#vi gammu.sh

File contents are as follows:
#! /bin/sh
export LANG=da
DK
/usr/local/bin/gam you –smsd MYSQL/etc/smsdrc

After edited that file open /etc/inittab

#vi /etc/inittab

And add the below line in the inittab

GA:345:respawn:/usr/local/bin/gammu.sh

Wow… was long enough also, hmmm hopefully did not have the problem ya… now finished your coffee, until you finished developed the SMS Gateway by using Gammu.
If you are having comments and questions, do not hesitate, just feel free to ask.

Ref : http://www.syednetworks.com/opensourc-sms-gateway-using-gammu-and-mysql

Writer Using

  1. HP SE K790i
  2. OS Ubuntu 9.04

Install Step By step

1.Install gammu

$sudo apt-get install gammu

$locate smsdrc

$cp /usr/share/doc/gammu/examples/config/* .

$gunzip smsdrc .gz gammurc.gz

$sudo cp smsdrc gammurc /etc

$sudo vim /etc/gammurc

#change this line

[gammu]

port = /dev/ttyACM0
connection = at19200

; Do not use model configuration unless you really need it
;model = 6110
;synchronizetime = yes
;logfile = gammulog
;logformat = textall
;use_locking = yes
;gammuloc = locfile
;startinfo = yes
;gammucoding = utf8
;usephonedb = yes

#save

$gammu --configure

Manufacturer : Sony Ericsson
Model : K790i/K790c (AAF-1022011-BV)
Firmware : R8BF003 080130 2133 CXC1250481_CHINA_EV
IMEI : 352206010781695
Product code : AAF-1022011-BV
SIM IMSI : 510219160664064

$echo "tes sms server" | gammu --sendsms TEXT 085691662771

If you want break, press Ctrl+C...
Sending SMS 1/1....waiting for network answer..OK, message reference=203

test sms server will send to destination number.

2.Connect to Database mysql

$gunzip mysql.gz

$mysql -uroot -pyourpassword

Your MySQL connection id is 81
Server version: 5.0.75-0ubuntu10.2 (Ubuntu)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> create database smsserver;
Query OK, 1 row affected (0.03 sec)

mysql> exit
Bye

$mysql -uroot -pyourpassword smsserver <>

SMS Database has been imported now.

$sudo vim /etc/smsdrc

# ----------------- SETTINGS FOR --smsd MYSQL or --smsd PGSQL -------------------
user = root
password = yourpassword
pc = localhost
# pc can also contain port or socket path after colon (eg. localhost:/path/to/socket)
database = smsserver

$wget http://www.syednetworks.com/gammu-sms-gateway.zip

$unzip gammu-sms-gateway.zip

$sudo mv gammu-sms-gateway/* /var/www/gammu

$sudo chmod -R 777 /var/www/sms

Edit your sms.php on /var/www/sms

mysql_connect("localhost", "root", "yourpassword") or die(mysql_error()); //connect to mysql
mysql_select_db("smsserver") or die(mysql_error()); //select database

Run SMS gateway and it will take all of your inbox(all inbox will remove to database).

$gammu –smsd MYSQL smsdrc

Note:

Untuk mengirim sms dari aplikasi anda harus:

menambah permission /dev/ttyACM0

$sudo chmod o+rw /dev/ttyACM0

change this line on send-sms.php

        $destination = getPostVariable( 'destination' );
$message = getPostVariable( 'message' );
exec( '/usr/bin/gammu --sendsms EMS ' . escapeshellarg( $destination ) . ' -text ' . escapeshellarg( $message ) ); // try this one
//system( sprintf( '/usr/local/bin/gammu --sendsms EMS %s -text %s', escapeshellarg( $destination ), escapeshellarg( $message ) ) );
header( 'Location: ' . $_SERVER[ 'PHP_SELF' ] . '?accepted=yes' );
exit();

then send sms by aplication

3.Make SMS AutoRespond

run gammu sms-gateway

$gammu –smsd MYSQL smsdrc

make trigger in database smsserver

create trigger
smsserver.autorespond1
AFTER
INSERT
on
smsserver.inbox
for each row begin
if(New.TextDecoded = "REG COBA")
THEN
insert into outbox(DestinationNumber,
TextDecoded,Coding,CreatorID)values(New.SenderNumber,"Terima Kasih",'Default_No_Compression','1');
end if;
end

Send REG COBA to your phone no,
then you'll retreive sms

"Terima Kasih"

End Of the Game


reference : http://bagoesseptian.blogspot.com/2009/07/gammu-sms-gateway.html